The WordPress plugin, "Squirrly SEO" has released version 6.1.5, fixing two security vulnerabilities.  If you're running any version lower than 6.1.5 you should upgrade ASAP as the earlier versions do have exploitable vulnerabilities.

Wordfence reports that the two vulnerabilities are as follows:

Vulnerability 1: Privilege Escalation

CVSS Severity: 8.8 (High)

This vulnerability allows an attacker to modify plugin settings on a site with registration enabled. On a stand-alone basis the value to an attacker is relatively low, enabling them to do things like add or change the site favicon, upload featured images for posts or retrieve SEO settings for a post. As you’ll see below, the real danger with this vulnerability is when it is used in conjunction with another.

Vulnerability 2: Path Traversal

CVSS Severity: 8.1 (High)

This vulnerability allows an attacker to download any file from a WordPress server,including the wp-config.php file. That file includes database credentials for the website and other information that could potentially enable an attacker to gain full control of your site

In order to exploit this vulnerability there are two conditions that must be met: a specific plugin parameter must be set to a specific value and a favicon must be present. We have no way of estimating the percentage of websites running the Squirrly SEO that meet this criteria. However, it could be used in conjunction with vulnerability 1 above or any other privilege escalation vulnerability to significantly increase an attacker’s success rate. 


 

If you haven't yet signed up for LazyLizard's WordPress Security protection, please do so to get automatic updates for all your plugins as soon as they're released.  You will also get a free complete security audit of your WordPress site, along with our personal recommendations to keep your site as safe as possible.  

You do not have to host your website with LazyLizard in order to use our WordPress Security Protection. 


Monday, July 11, 2016







« Back